String input for undefined type



The 1C:Enterprise developers forum

#1
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

I was looking for a better way to sel ect data from a predefined list, so I decided to create a separate form to sel ect fr om.

Looking at ITS I have found out that it is recommended to use String input to select data. It is quite obvious how to use String input for an object defined in configuration, but what if I need to select fr om some data table which is not part of metadata?

Also, what is the best way to pass and receive data to selection form (custom data, not part of configuration). I have found recommendations, but for v.8.1 which is quite outdated.

 
#2
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

Update.

I have found a way how to solve the problem, but also I have discovered some strange behavior of the platform.

If you select "ListChoiceMode" for some input field, it still permits to select value which is not in the list by providing values via "ItemAutoComplete" event. And it is becoming very confusing. I have not noticed that "ListChoiceMode" checkbox was on, so after successful selection the selected value was just dropped without any warning.

 
#3
People who like this:0Yes/0No
Administrator
Rating: 16
Joined: Dec 4, 2017
Company:

Dear Alexey,

As for ListChoiceMode, could you please send us a description of what you did, what you expected to get, and what you actually got - with screenshots?

Best regards,
Vladimir Gurov

1C Company support team
 
#4
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

1. Sel ect "ListChoiceMode" for some input field

2. provide values which are not in the list via "ItemAutoComplete" event. (they will be displayed "correctly")

3. press Enter (or select) any value

4. You expect this value to be selected, but getting empty field without any warning

I have not noticed that ListChoiceMode was on. There were no warning that the value is not fr om the list. So I spent a good amount of time figuring out why selected value was dropped.

 
Subscribe
Users browsing this topic (guests: 1, registered: 0, hidden: 0)