Run Android Application service class

Discussions regarding 1C:Enterprise for mobile devices with Android, iOS, or Windows Phone.

#1
People who like this:0Yes/0No
Just came
Rating: 1
Joined: Sep 12, 2016
Company:

Hello,

I created an Android service. It's package is "com.test.servicetest". Service class is "MyService". How can I run this service from 1C mobile ?

I tried this way, but it won't run :

Code
#If MobileAppClient Then
   Application = New MobileDeviceApplicationRun();
   Application.Action = "com.test.servicetest.MyService";
   Application.Run(True);
#Endif

 
#2
People who like this:0Yes/0No
Timofey Bugaevsky
Guest

Joined:
Company:

Hello, Sebi Dan!

The syntax is correct.

Can you run your service class from other mobile application? Are you sure it is working outside 1C platform?

 
#3
People who like this:0Yes/0No
Just came
Rating: 1
Joined: Sep 12, 2016
Company:

Hello,

I tried to run the service from other android application and it starts with no problem. Android code used is this :

Code
            Intent intent = new Intent(Intent.ACTION_MAIN);
            intent.setComponent(new ComponentName("com.test.servicetest", "com.test.servicetest.MyService"));
            startService(intent);

I don't know why it won't run from 1C mobile.

 
#4
People who like this:0Yes/0No
Timofey Bugaevsky
Guest

Joined:
Company:

Hello, Sebi Dan!

MobileDeviceApplicationRun stands for Activity.startActivityForResult(Intent, RequestCode)

Also, in your case you need to initialize MobileDeviceApplicationRun with "android.intent.action.MAIN" because you did it in your example of running in other program:

Code
   Application = New MobileDeviceApplicationRun("android.intent.action.MAIN");
   Application.Action = "com.test.servicetest.MyService";
   Application.Run(True);

 
#5
People who like this:0Yes/0No
Just came
Rating: 1
Joined: Sep 12, 2016
Company:

Hello, Timofey !

I tried like you said but it won't run the service.  I think it is bug here. The code runs with no errors, but it does nothing. I am using 1C:Enterprise 8.3 (8.3.8.1652) and 1C:Enterprise 8.3(8.3.8.58) ( Android ).

 
#6
People who like this:0Yes/0No
Just came
Rating: 1
Joined: Sep 12, 2016
Company:

A few moments ago I tried creating the *.xml file on desktop using 8.3.9 and run it on mobile ( 8.3.9.74 ) and the result is the same, no service started.

 
#7
People who like this:0Yes/0No
Just came
Rating: 1
Joined: Sep 12, 2016
Company:

I sent you a private message with all the details. Thank you !

 
#8
People who like this:0Yes/0No
Timofey Bugaevsky
Guest

Joined:
Company:

There are two ways for this:

  • Create empty Activity without displaying it, in OnCreate start the service if it is not started and close activity. Please note that the best practice is to inform a user when the service is started.
  • Use the mobile platform 8.3.9, create an external component that will call startService.

 
Subscribe
Be the first to know tips & tricks on business application development!

A confirmation e-mail has been sent to the e-mail address you provided .

Click the link in the e-mail to confirm and activate the subscription.