Problem with SupplierInvoice Posting

Powerful and flexible application for small business management. See 1C:Small Business description

#1
People who like this:0Yes/0No
Just came
Rating: 1
Joined: May 26, 2016
Company:

1C:Enterprise 8.3 (8.3.8.1784)
Small Business, version 1.5 (1.5.3.38)

When I do posting from Document form I catch an error

"Error running processor - 'Posting'
, reason:
{CommonModule.SmallBusinessServer.Module(2084)}: Error calling context method (Write)
RecordSet.Write();
, reason:
Record is invalid! Credit account is missing (Accounting register: Posting journal; Line number: 1)"


UPD. I figured out that ObjectModule Procedure BeforeWrite lose Ref.Counterparty

but when I do posting from document list - all OK

Edited: Anton Lipskiy - Jul 27, 2016 06:04 AM
 
#2
People who like this:0Yes/0No
Timofey Bugaevsky
Guest

Joined:
Company:

Hello, Anton!

Thank you very much for this information. I have sent it to the developer team and it will be fixed in the next version of 1C:Small Business.

 
#3
People who like this:0Yes/0No
Just came
Rating: 1
Joined: May 26, 2016
Company:

The same problem in CustomerInvoice

 
#4
People who like this:0Yes/0No
Timofey Bugaevsky
Guest

Joined:
Company:

Thank you very much, Anton!

This problem will be fixed in the next version too.

 
Subscribe
Be the first to know tips & trick on business application development!

A confirmation e-mail has been sent to the e-mail address you provided .

Click the link in the e-mail to confirm and activate the subscription.