Blury text on system with DPI scaling



The 1C:Enterprise developers forum

#1
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

It seems like 1C:Enterprise does not know how to correctly handle DPI scaling on Windows 10. On the system with HiDPI primary (2560x1440 200%) and normal (1600x1200 100%) secondary display the text is very blurry on secondary display. I can't actually confirm that it is blurry on HiDPI display because the pixel size is so small that you can not notice it, but on the secondary display the text is blurry to the point that is provokes headache.
Also I have noticed that list form column sizes are incorrect on HiDPI display.

The only thing that helps is enabling "Fix scaling for apps" in recent version of Windows 10. Platform 8.3.12.1529. This fox only works for primary display (I had to change primary and secondary to make this work)

   Quote selected text in answer   Name
#2
People who like this:0Yes/0No
Administrator
Rating: 16
Joined: Dec 4, 2017
Company:

Dear Alexey,

Have tried fix scaling for apps by using the Compatibility tab (as described here: https://winaero.com/blog/fix-scaling-apps-windows-10/)?

If yes, could you please send us a couple of screenshots that illustrate a 1C:Enterprise application running at your primary and secondary displays?

Best regards,
Vladimir Gurov

1C Company support team
Quote selected text in answer   Name
#3
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

With all the fixes enabled in windows 10, I am getting adequate main window, but look what happened with calc!

Quote selected text in answer   Name
#4
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

Without "Fix scaling for apps" it is very blurry.
Should not it work fine without any tweaks? I mean our clients are not tech experts and if they have same problems as I do, they will probably have no clue how to solve it. It is 2018 and it is quite common the use of Windows 10 and HiDPI monitors. Platform should correctly handle scaling without any tweaks.

Quote selected text in answer   Name
#5
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

This is another example from HiDPI monitor, 200% scaling, no fix enabled. Please note, that all column sizes seems to be half the size.

Quote selected text in answer   Name
#6
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

With "fix" enabled, same computer.
It is noticeable that the icons were reduced in half, still column sizes are incorrect

Quote selected text in answer   Name
#7
People who like this:0Yes/0No
Administrator
Rating: 16
Joined: Dec 4, 2017
Company:

Dear Alexey,

As a workaround for tweaking the way your 1C:Enterprise applications display table data, you can use the change scaling functionality, which is described here (in Russian):

https://wonderland.v8.1c.ru/blog/bystroe-masshtabirovanie-form/

Below is the description of Windows scaling issues related to applications running on multiple monitors having different resolutions and DPI:

https://support.microsoft.com/en-us/help/3025083/windows-scaling-issues-for-high-dpi-devices

As you can see, the issues are rather sophisticated and so far there is no simple solution that fits everyone.

Also, here is the description of the fact and reasons why 1C:Enterprise applications are System DPI-aware (in Russian):

https://wonderland.v8.1c.ru/blog/yuzabiliti-interfeysa-taksi-v-versii-8-3-6/#dpi

(by using Sysinternals Process Explorer, you can ensure that 1C:Entprise applications are indeed System DPI-aware under Windows 10)

Best regards,
Vladimir Gurov

1C Company support team
Quote selected text in answer   Name
#8
People who like this:0Yes/0No
Interested
Rating: 34
Joined: Oct 27, 2011
Company: Abaco Soluciones S.A.

Vladimir, I have found out that I am getting more stable form presentation with 8.3.12 and compatibility mode off.
But I can not disable compatibility because of the issue form this topic. https://1c-dn.com/forum/forum17/topic1999/
Is there any workaround for the issue?

Quote selected text in answer   Name
#9
People who like this:0Yes/0No
Administrator
Rating: 16
Joined: Dec 4, 2017
Company:

Dear Alexey,

A reliable solution is to get the expected fix for https://1c-dn.com/forum/forum17/topic1999/.

Best regards,
Vladimir Gurov

1C Company support team
Quote selected text in answer   Name
Subscribe
Users browsing this topic (guests: 0, registered: 1, hidden: 0)