Different roles on different WebServices NOT WORKING



This forum is intended for cases when a problem can not be solved due to restrictions of the platform: a bug or lack of functionality.

#1
People who like this:0Yes/0No
Active user
Rating: 2
Joined: Jul 24, 2017
Company: Smart ID Dynamics

Hello guys.

I have a problem in 1C Platform version 8.3.8.1652. I have 2 different WebServices ( let's assume WebService1 and WebService2 ) and I created 2 roles that have specific rights. First role has access granted to WebService1 specifically ( and does not have any access on WebService2 ) and the second role has access granted to WebService2 ( and not WebService1 ).

I assume that you get the point of what I am trying to do here: 2 diferent users that can access only their WebServices ( user1 - ws1 ; user - ws2 ) and any of the users cannot access other WebServices, but their own.

The problem comes when I try to access the WSDL on each WebService, because I can login to any of the wsdl's with any user. The platform doesn't take into account my specific roles.

Example:
localhost/MyDemoApp/ws/WebService1?wsdl : this can be accesed even with user2 that has granted access only on WebService2.

Does anyone have a solution for this specific problem?

 
#2
People who like this:0Yes/0No
Administrator
Rating: 22
Joined: Dec 4, 2017
Company:

Dear Lucian,

Have you tried switching to a newer version of 1C:Enterprise Platform (say, 8.3.13)?

If yes, does the issue persist?

Best regards,
Vladimir Gurov

1C Company support team
 
Subscribe