Using web services in 1C

Discussions regarding 1C:Enterprise for mobile devices with Android, iOS, or Windows Phone.

#1
People who like this:0Yes/0No
Active user
Rating: 2
Joined: Aug 28, 2015
Company:

Hello everyone!
My task is to create a mobile app which will allow to browse reports formed on a server. On the server side I've created web service with several operations. One of these operations receives parameters from mobile app(name of the report, etc.) ,  generates the report and returns a spreadsheet document to a mobile app.

The default run mode on the sever is set as Ordinary application.

There's no problem when the report is made with data composition schema but  when the report is made manually and all the procedures are in its object module,when I call these procedures  the system shows errors.

 
#2
People who like this:0Yes/0No
Timofey Bugaevsky
Guest

Joined:
Company:

Hello, Samir Muqimov.

Please, see Chart on a mobile device.

Hope, this helps.

 
#3
People who like this:0Yes/0No
Active user
Rating: 2
Joined: Aug 28, 2015
Company:

Hello, Timofey Bugaevsky.

Thanks for your comment. But the link that you gave me above didn't help me.
Let me explain how it all works.
As I said before, my function that I wrote in web service accepts the parameters from mobile device and calls the function from common module. This common module creates the object Report. About 95 percent of all reports are made manually without using data composition schema (about 500 reports). All the examples that I found on the internet and that you gave me were made with data composition schema.

I have no problems with sending the SpreadSheet document. The problem is that I can't  call the procedures from its object module.
I don't understand why the procedures are not available from the web service because when I use that common module from external data processor without using web service there are no errors.

The same error appears both on a mobile device and  a computer:

Object method not found (SetInitialSettings)

 
#4
People who like this:0Yes/0No
Timofey Bugaevsky
Guest

Joined:
Company:

Samir Muqimov, please, provide a sample infobase where I could reproduce this issue and steps to reproduce it.

Think, you are calling a procedure of a module that is not available for web service. Maybe you are calling a Client module procedure which is not available on server.

 
#5
People who like this:0Yes/0No
Active user
Rating: 2
Joined: Aug 28, 2015
Company:

Hello, Timofey Bugaevsky.
Thank you so much for your help. Problem solved. You're absolutely right all the procedures and functions in this module were predefined between  
&If Client then

&Endif

Thanks again.

Edited: Samir Muqimov - Nov 13, 2015 04:14 AM
 
Subscribe
Be the first to know tips & tricks on business application development!

A confirmation e-mail has been sent to the e-mail address you provided .

Click the link in the e-mail to confirm and activate the subscription.